跟上我们的目标来清理Jenkins核心内部的一些技术债务并减少维护开销,我们很乐意报告我们能够删除一款长期弃用的Apache Commons 必威国际有限公司Digester库。

在Jenkins核心升级后,某些插件将需要更新以正常运行。必威国际有限公司看Jep-231.对于受影响的插件的完整列表。下面有一个插件列表所做的不是在撰写本文时释放其修复。他们将在6月7日开始与每周打破,预计将成为2.297。

除了这些静件的插件外,还有一些其他人会破裂。但请注意,这些是已经暂停[1]出于各种原因,所以我们建议远离使用它们或加强作为维护者。这些插件的ID是:TFS.SVN-Release-MGRCPPTEST.cflint.脚本-CCM.RTC.

更新所有插件总是一个好主意升级Jenkins 必威国际有限公司Core。

请伸出援手开发人员列表有任何问题或建议。

在受影响的插件中获取修复

对于所有受影响的插件,我们已提交使用兼容性补丁的拉拔请求。这些插件似乎没有活动维护者,因此我们无法承诺提供这些修复程序。同时,您可以在本地构建自定义修补程序以解决您实例上的问题。如果您使用这些插件中的任何一个,请考虑加紧升级和采用它们以便可以释放修复程序。我们将欣赏任何贡献!

资源

PR-5320

删除Commons Digester:2.1。这还包含一个完整的受影响的插件列表及其PRS和状态。

Jep-231.

描述这种变化。


1。这意味着Jenkins项目的托管服务不再提供这些插件。必威国际有限公司即使他们被释放,在修复了其他问题之前,发行将不会出现。
关于作者
Baptiste Mathus.

Baptiste一直在使用和贡献Jenkins,因为它被不同地称为不同的,并且是敏捷,D必威国际有限公司evops和持续交付运动的巨大支持者。他不仅喜欢讨论技术方面,而且还有更为基本的文化方面,也可以共同努力,以改善客户提供的价值,以伟大的包容性和无可指责的环境。